Intermittent performance issues - Some data may take longer than usual to appear

Incident Report for SimpleConsign

Resolved

The intermittent slowness we reported earlier has been resolved. SimpleConsign is now performing normally and all data, including transactions and inventory that may have been delayed, should be fully up to date.

If you are still seeing any missing data or unexpected behavior, please reach out to our support team and we will get it sorted out right away.
Posted Mar 25, 2026 - 14:06 CDT

Investigating

We are currently experiencing intermittent site slowness that may cause a delay in data appearing in SimpleConsign — including recently completed transactions and newly added inventory. Your data is saved and will appear shortly once performance normalizes.

We are actively working to stabilize performance and will post an update here when the issue is fully resolved. Thank you for your patience.
Posted Mar 25, 2026 - 13:06 CDT
This incident affected: SimpleConsign (SimpleConsign App).