We're sorry — site slowness is affecting SimpleConsign again

Incident Report for SimpleConsign

Resolved

After closely monitoring the situation, we are confident SimpleConsign is fully stable. Any delayed transactions and inventory updates should now be caught up in your account.

We sincerely apologize for the disruptions this week. The root cause has been identified and measures to prevent recurrence are being put in place.
Posted Mar 27, 2026 - 20:20 CDT

Monitoring

System performance is looking better. SimpleConsign appears to be stable and our team is closely monitoring the situation to make sure it holds. Given the recurring nature of this issue, we want to be certain before calling it fully resolved.

We have identified the root cause behind the repeated incidents this week and are actively making strides to prevent this from happening again. We are not going to consider this fully resolved until those measures are in place.
Posted Mar 27, 2026 - 16:20 CDT

Identified

We want to give you a quick update: our team is actively working toward a resolution and we expect to have one in place shortly. We appreciate your continued patience while we work through this.
Posted Mar 27, 2026 - 15:58 CDT

Investigating

We know how frustrating it is to see this message for the third day in a row and we sincerely apologize. Despite the fix we deployed yesterday, we are again seeing intermittent performance issues affecting SimpleConsign. Transactions and inventory updates may be delayed in appearing.

Your data is safe and nothing has been lost. As with the previous incidents, any delayed data will appear once performance is restored.

We recognize that repeated disruptions like this are unacceptable and we are not taking that lightly. Our team is fully focused on understanding why this issue continues to resurface and are focused on a permanent resolution.
Posted Mar 27, 2026 - 14:42 CDT
This incident affected: SimpleConsign (SimpleConsign App).