Editing a consignor is causing an error
Incident Report for SimpleConsign
Resolved
Development updated to production to fix an error related to SimpleCollect
Posted Mar 16, 2023 - 09:29 CDT
Investigating
Development is investigating now
Posted Mar 16, 2023 - 09:01 CDT
This incident affected: SimpleConsign (SimpleConsign App).