Check Printing and Avery Labels are down.
Incident Report for SimpleConsign
Resolved
This incident has been resolved.
Posted Dec 21, 2022 - 11:26 CST
Update
Check printing is working!
Avery Labels are working now too! You may have to refresh your screen when the blank screen for checks comes up. Then they will load.
Posted Dec 21, 2022 - 11:19 CST
Investigating
We are currently investigating this issue.
Posted Dec 21, 2022 - 10:28 CST