Fix in progress - We've identified the cause and are deploying a fix now

Incident Report for SimpleConsign

Resolved

The fix we deployed earlier today has held and SimpleConsign is fully operational. All delayed data, including transactions, inventory, and Shopify sync, should now be caught up and displaying correctly.

We apologize for the disruption this caused throughout the day. The underlying bottleneck has been addressed and we do not expect this issue to recur.

If anything still looks off in your account, please reach out to our support team and we will assist you.
Posted Mar 26, 2026 - 16:05 CDT

Monitoring

We have deployed the change targeting the bottleneck behind today's recurring performance issues. Performance appears to be stabilizing and we are actively monitoring to confirm the fix holds.

Delayed data, including transactions, inventory, and Shopify sync, should begin catching up shortly. Shopify inventory may take additional time to fully sync, but no action is needed on your end.

We will post a final resolution update once we are confident the issue is fully behind us. Thank you for your patience throughout today.
Posted Mar 26, 2026 - 14:14 CDT

Identified

We are sorry to report that the performance issue has returned. We understand this has been disruptive and we are treating this as our top priority.

The good news: we have identified the bottleneck responsible for these recurring issues and are pushing out a change now that we expect to address this permanently. We will confirm once the fix is live and performance has fully stabilized.

In the meantime, transactions, inventory updates, and Shopify sync data may continue to be delayed in appearing. All of your data is safe, nothing has been lost and everything will catch up once the fix is in place.

We appreciate your patience today and will post a full resolution update shortly.
Posted Mar 26, 2026 - 14:10 CDT
This incident affected: SimpleConsign (SimpleConsign App).